Channel Manager booking processing issue
Incident Report for TrekkSoft
Postmortem

Root cause:
Memory shortage on one of the servers caused bookings from OTAs not to be created on the internal booking system.

What happened:
Bookings from OTAs were taken by the channel manager but were not translated into bookings on TrekkSoft.

What we did:
Our developers pinpointed the specific services that were affected and were not performing correctly. These services were restarted and this solved the issue.

The consequences:
Most bookings taken during the down time were created on TrekkSoft after the issue was resolved. Only bookings for activities that already took place, or have meanwhile run out of seats, were not created on TrekkSoft. Providers receive email notifications about these failed bookings and should check their email inboxes. Refunds for failed bookings through the OTAs should be made by providers through the OTAs.

We apologize for the inconvenience.

Posted Aug 12, 2020 - 14:18 CEST

Resolved
Issue Resolved: The Experience/TrekkConnect channel manager is working again as expected.
Bookings that were made during this partial outage were stored and are now being carried over to the booking system.
Posted Aug 11, 2020 - 14:15 CEST
Investigating
We are experiencing issues with bookings coming in through our channel manager: TrekkConnect / ExperienceBank. A proportion of these bookings are currently not being processed. The main affected channels are Get Your Guide and Viator.
Our developers are looking into finding the root cause of this issue.
We will keep you updated and apologize for the inconvenience.
Posted Aug 11, 2020 - 09:41 CEST
This incident affected: Channel Manager.