Registered issue: Custom Domains not accessible

Incident Report for TrekkSoft

Postmortem

Incident Date: April 16th 2025
Incident Duration: Approximately 4 hours
Affected Services: TrekkSoft Backoffice, TrekkSoft Website Builder

Incident Description: On April 16th, around 18:00 CEST, our system was hit by an attack that caused unusually high network traffic. This led to about 4 hours of downtime, during which the system was unusable for those using a custom domain.

Impact: The outage of approximately 4h affected the Backoffice and Website Builder sections of the system.

Resolution: Once we identified the source of the attack, we blocked it to stop the issue.

Preventive Measures: We are now working on strengthening our protection and improving how quickly we can detect and respond to similar problems in the future.

Posted Apr 23, 2025 - 17:13 CEST

Resolved

The incident has been resolved, and all TrekkSoft functionalities are operating as expected since Wednesday, 22:16pm CEST.

Our investigation revealed that an attack happened affecting custom domains. We aim to publish a detailed post-mortem later today.

We sincerely apologize once again for any inconvenience caused.
Posted Apr 17, 2025 - 09:08 CEST

Monitoring

Custom domains are now accessible again. The root cause of the issue was an attack, which was now successfully being blocked. We will keep monitoring the situation.
Posted Apr 16, 2025 - 22:36 CEST

Investigating

We are currently experiencing issues with custom domains not being accessible. Therefore the option to book might be limited.

Our developers are already investigating the root cause of the issue.

We apologize for any inconvenience this may have caused and appreciate your patience as we work to resolve the issue. If you have any questions or concerns, please don't hesitate to contact us. We will make sure to keep you updated on the progress of this issue.
Posted Apr 16, 2025 - 21:09 CEST
This incident affected: TrekkSoft Backoffice and TrekkSoft Website Builder.