Incident registered

Incident Report for TrekkSoft

Postmortem

Incident Date: June 30th 2025
Incident Duration: Approximately 45 min
Affected Services: TrekkSoft Backoffice

Incident Description: On June 30th, around 20:00 CEST, our system went unresponsive, causing an intermittent downtime of approximately 45 min. This was due to a node’s failure that led to a boost in database connections which crashed the system.

Impact: The unresponsiveness of approx 45 minutes resulted in issues accessing the Backoffice or receiving online bookings.

Resolution: Once we identified the faulty part, the node was rebooted and this fixed the issue.

Preventive Measures: We will be working on improving how quickly we can detect node failures and reviewing whether there is a need to add additional nodes.

Posted Jul 02, 2025 - 15:28 CEST

Resolved

The incident has been resolved, and all TrekkSoft functionalities are operating as expected.

The intermittent failure was due to a database overload. A more detailed explanation of the incident will be shared as soon as possible.

We sincerely apologize once again for any inconvenience caused.
Posted Jul 01, 2025 - 09:07 CEST

Monitoring

The system has been stable and fully operational since 10:15 PM CEST on June 30. We will continue to monitor the situation closely and provide a more detailed update later today.
Posted Jul 01, 2025 - 07:55 CEST

Investigating

We are currently experiencing intermittent system failures due to a database overload.

As a result, you may encounter issues accessing the backoffice or receiving bookings online.

Our team is actively working to resolve the issue, and we apologize for any inconvenience this may cause
Posted Jun 30, 2025 - 22:06 CEST
This incident affected: TrekkSoft Backoffice, TrekkSoft API, TrekkSoft Mobile App (mPOS), POS Desk, and TrekkSoft Website Builder.