Trekksoft Booking Widget Global Issue
Incident Report for TrekkSoft
Postmortem

What happened?

Our developers were working on booking widget improvements and along with that they released a new version which included infrastructure changes. Those changes unexpectedly impacted the main functionalities and prevented end customers from booking the activities.

What we did?

As soon as this issue has been detected, our developers started working on it’s resolution first by rolling back to the previous version and later on providing a new healthy release with re-caching solution.
Issue was fixed 2h and 37 min after the initial detection.

Impact

Booking widget functionalities were impacted for some merchants and end customers:

  1. merchant impact: All the accounts without “en_GB“ language as default weren’t able to receive bookings.
  2. end customer impact: Customers using safari browser / apple devices were unable to proceed with bookings on booking widget.

Learnings

In order to prevent similar issues in the future we introduced additional tests which are executed on different browsers and systems each time new booking widget version is released.

Posted Jul 01, 2022 - 13:18 CEST

Resolved
This incident has been resolved and booking widget is working as expected without issues.

Our developers were able to clear the cache as well, which means that manual clearing of cache is no longer needed.

Postmortem on the issue will be provided in the following days.

Once again, we apologise for any inconvenience this might have caused you and thank you for your patience.
Posted Jun 08, 2022 - 16:40 CEST
Monitoring
A fix has been implemented and the booking widget is working now as intended. We will keep monitoring the behaviour to make sure the issue is completely resolved and it doesn't appear again.

NOTE
If you are still experiencing issue with availabilities not showing, please clear the cache.
Posted Jun 08, 2022 - 14:43 CEST
Identified
An issue has been identified with our booking widget which is not working properly for end customers trying to make bookings in Safari (either mobile or desktop) and Chrome (only mobile) web browser.

Our developers already identified the root cause of the issue and are currently working on it's resolution.

We will keep you updated and we apologize for any inconveniences this might have caused.
Posted Jun 08, 2022 - 12:36 CEST
This incident affected: TrekkSoft Application and Backend Mobile Applications.