Issues with support systems
Incident Report for TrekkSoft
Resolved
All systems are working correctly and we are able to give service regularly again.
Posted Feb 07, 2020 - 09:15 CET
Update
Our provider has advised they have addressed the issue which was causing a delay however, some issues could still occur. Our provider will continue to monitor the performance until the issue is fully resolved.

We apologise for any inconvenience that this may cause.
Posted Feb 06, 2020 - 17:49 CET
Monitoring
Our provider for the software we use to answer support related question such as chat and email, is experiencing issues. At the moment we do not have an update on when the issue will be resolved. Customers reaching out to us for support should be prepared for a longer than usual wait.
Posted Feb 06, 2020 - 16:56 CET